OUR NETWORK: TiVo Community TechLore Explore3DTV DVRplayground Dijit Community See all... About UsAdvertiseContact Us

 
Learn about scoring Forum's Raw Score: 234352.0
November 21, 2010 09:55 AM

Categories: Sansa Clip / Clip +

Rating (0 votes)
  • 1
  • 2
  • 3
  • 4
  • 5
Rate This!

Member Avatar

DonaldH

Member
Joined: 11/21/2010

I purchased a sansa clip plus recently, primarily for listening to audio book.  And I LOVED it.  I liked it so much that I got my wife one.  Then we ran into a problem with the way audio books are played.

We both have a Sansa Clip Plus with firmware V01.02.15A and we copy audio books to the SANSA in MSC mode.

BUT, I use linux.  It appears that linux always copies the files in alphabetical order.  My wife uses windows, and windows does NOT always copy files in alphabetical order. 

And thus the problem with the sansa clip audio book playback that *I* did not notice.  Within a book (as determined by the album tag) It orders the chapters by the order in which they were copied to the player.  It does NOT order them by the filename.  It does NOT order them by the title tag.  It does NOT order them by the track tag.   I was able to reproduce this problem on my player in linux by deliberatly copying the files out of order.  I reproduced this problem with different books, and on both players.

So, for example, If I have an audiobook on my computer that looks like this:

Folder:Godwin_SpacePrison

  • spaceprison_01_godwin_64kb.mp3
  • spaceprison_02_godwin_64kb.mp3
  • spaceprison_03_godwin_64kb.mp3
  • spaceprison_04_godwin_64kb.mp3

Then I plug in the sansa clip plus, and under AudioBooks create the same folder, then copy in the files out of order:

Folder:/media/SANSA CLIPP/AUDIOBOOKS/Godwin_SpacePrison

  • spaceprison_04_godwin_64kb.mp3
  • spaceprison_02_godwin_64kb.mp3
  • spaceprison_01_godwin_64kb.mp3
  • spaceprison_03_godwin_64kb.mp3

Once I disconnect the player, the chapters will appear on the sansa in the order in which they were copied.  4,2,1,3.   It does not sort them by filenamet or title or track!

Like I said, on linux this isn't a problem because (at least in all of my tests so far) if I copy a folder (or even just a selection of chapters) and paste them to the sansa, it copies them in alphabetical order.  But if I boot into windows xp on my machine, or windows 7 on my wife's machine, and do a mass copy/paste, the order in which they are copied is not entirely alphabetic and the sansa plays the chapters out of order.

Of course, the simple fix for this is for my wife to copy one chapter at a time to the sansa, but that is annoying.  And it just seems strange that the sansa wouldn't sort by filename or tag?

(and the problem would ALSO dissapear if I could convince my wife to use LINUX!) :)

Am I doing something wrong, or is there a setting I need to flip?

thank you very much for any help!

Discussion:    Add a Comment | Comments 1-3 of 3 | Latest Comment

January 23, 2011 3:26 AM

Donald,

you should have a look at fatsort, a command line tool for sorting directory records right on a FAT media. Using the options -n -c ("natural order sorting", "ignore case") it even handles odd folder names like "cd1 Cd02 CD03 cd4".

Gert

January 24, 2011 9:40 AM

I also use Linux, but my recollection is that if you use Windows Media Player to copy the files to the device instead of Explorer they are copied in track order.

March 24, 2011 12:57 PM

Try this:

After selecting All of the mp3 files from the PC, click on the top file in your list and drag to the Sansa player. It will copy in the same order.

Discussion:    Add a Comment | Comments 1-3 of 3 | Latest Comment

You must login to discuss this item.

 
 

Please log in or register to participate in this community!

Log In

Remember

Not a member? Sign up!

Did you forget your password?

You can also log in using OpenID.

close this window
close this window